Community

Instructor Q&A
0

OneDrive Assignment

Follow

When attempting to add a file from OneDrive to an assignment, OneDrive is not loading for teachers to view their files. It looks like it's loading, but never displays the content of their OneDrive. The only thing they can click on is the x to close the window.

Answered

2 comments

  • Avatar
    Nina Rivera Official comment

    Hi Mike,

    Thank you for reaching out in the Schoology Community!

    We have found that this issue can sometimes be solved by reconnecting the Onedrive account and un-blocking 3rd party cookies on the browser. Below I have included the step to reconnect the Onedrive account and unblock 3rd party cookies on several browsers.

    In your Onedrive account:

    1. Select Settings

    2. Under "Your App Settings", Select Office 365

    3. Select App Permissions

    4. Select "Revoke" for the Schoology Microsoft Integration


    Now, go back to Schoology, and connect again to the Onedrive App.

    3rd Party cookies:

    Google Chrome
    1. Navigate to: chrome://settings/content/cookies
    2. Make sure that "Block 3rd party cookies" is turned off.

    Firefox
    1. Navigate to: about:preferences#privacy
    2. Under History change it to "Use custom settings for history"
    3. Make sure that "Accept cookies from sites" is checked off and "Accept cookies from sites" is set to Always.

    Internet Explorer
    1. Select the Tools button
    2. Select Internet options.
    3. Select the Privacy tab
    4. Under Settings, select Advanced and choose to allow third-party cookies.

    Please let me know if this helps!

    Best,

    Nina Lewis 

    Community Communications Specialist 

    Schoology | A PowerSchool Unified Classroom Product

     

    Edited by Nina Rivera
  • 0
    Avatar
    Mike Munski

    Thank you for this. I tried everything stated above with no success. It's very weird as with my account, I'm able to attach a file with the OneDrive assignment feature, but then as I have a teacher log on to my computer and she tries, she's unable to. We're hearing from more and more teachers that are encountering this error. Could it be more account-based compared to computer-based?

Please sign in to leave a comment.
Powered by Zendesk