Troubleshooting Invalid Adapter Credentials Within SIS App

Follow

Question

As a System Administrator, when I navigate to the Configuration area of my PowerSchool SIS app, the following error is displayed:

Your adapter credentials are invalid, please try to reconnect or enter new information

PS_creds_error.png

Additionally, teachers are reporting a frowning-face error within their PowerTeacher apps:

PS_Teacher_error.png

How do I resolve this issue?

Answer

As a first step, we recommend re-entering your credentials:

  1. Clear the credentials from the SIS app and save them to your clipboard.
  2. Click Save API Credentials.
  3. Re-enter your credentials.
  4. Click Save API Credentials again.

The error should resolve and teachers should be able to access their course-level PowerSchool apps.

If you encounter an error when re-saving the API credentials, try these troubleshooting tips:

  1. Make sure there are no spaces before and after the PowerSchool Domain, Consumer Key, and Consumer Secret entries.
  2. Double-check that you've entered the PowerSchool domain URL accurately and, if appropriate, be sure to include https:// or http:// before the domain.
  3. Check that you have enabled SSL in the Global Server Settings of your PowerSchool instance:
      • In PowerSchool, go to System > System Settings > Global Server Settings.
      • Make sure that Secure Server SSL is enabled and saved.

For full details, please review the PowerSchool Implementation and Configuration Guide.

If this does not resolve the issue, we recommend resetting the Consumer Key and Secret following the steps outlined here.

Note: If the error persists after taking these steps, contact Schoology Support with your PowerSchool Domain, Consumer Key, and Consumer Secret information.


Comments

0 comments

Article is closed for comments.

Powered by Zendesk