How Do I Export Grades?

Gradebook Export Formats

You can export a course gradebook in two formats:

  • Gradebook as CSV:
    • Select this option to download a CSV file version of your gradebook. This spreadsheet is formatted similarly to how it is in Schoology, with the student names vertically and material titles along the top.
  • CSV for import into other system:
    • Select this option to download a CSV file with more detailed student data. This spreadsheet is separated by columns for mapping purposes to use to import into another system, such as an SIS gradebook.

To export your course gradebook:

  1. In your course, click Gradebook in the left menu.
  2. Click the menu icon (three vertical dots) in the upper-right corner.
  3. Select Export in the menu.

Grade Calculation Differences

There are several important differences in how grades are calculated between the two formats.

  Gradebook as CSVCSV for import into
other system
Hidden or Unpublished Materials Are not included in Overall or Grading Period grade calculations. Are included in Overall or Grading Period grade calculations.
Factors Items with a factor are multiplied by that factor and then included in the final score.  Items with a factor are not multiplied by that factor before being included in the final score.
Weighted Categories Do impact grade calculations.  Do not impact grade calculations.

 

Be sure to consider these variables when deciding the format in which to export your gradebook.

Encoding Settings

If you are using Schoology in a double-byte language, such as Japanese, Chinese, or Korean, you may have to change the encoding of the CSV file to correctly display the characters.

To change encoding settings in Microsoft Excel, open the Options menu. In Excel 2013, Options is in the File menu in the top row; previous versions of Excel access Options from different locations (the Microsoft logo button in Excel 2010, for example).

  1. Select Advanced from the Options menu.
  2. In the General section, click Web Options.
  3. On the Encoding tab, choose the appropriate language from the Save this document as list: For example, select Japanese (JIS) to display Japanese characters.
  4. Click OK to close the Web Options menu.

Powered by Zendesk