Export (Enterprise)

Follow

Export allows you to export a CSV file of user, course, section, course enrollment, gradebook, and attendance information. Each of these areas for export is located at the top of the Export area.

Users should have a User Unique ID, courses should have a course code, and sections should have a section code or section school code in Schoology for successful exports.

Note: Schoology is optimized for imports and exports to process most quickly between the hours of 7pm to 6am Eastern Time (ET) from Monday to Sunday. Schoology strongly recommends performing or scheduling all imports, exports, and bulk deletions during this time frame, including manual imports as well as scheduled auto-imports.

Use these links to jump to a specific area of the guide:

Exporting Users

The Users tab provides the ability to export users in your school. To export user information, follow this process:

  1. Select fields—Select the Fields (types of information) to export. Each field will export a column of user information, which you may filter as needed. 
  2. Click Export—To export a CSV file of the selected information, click the Export button. 

For information on exporting a file with the goal of marking graduated students and their parents as Inactive, click here. 

Back to top

Exporting Courses

Use the Courses tab to export your school's course information:

  1. Select grading period–Select the grading period(s) associated with the courses you’d like to export. 
    • Select Active–Selecting this option will select all current grading periods at your school. Current grading periods are grading periods that have started, but not yet ended.
  2. Choose courses–Select the course(s) you’d like to export. If there are more than 500 courses associated with the selected grading period(s), Schoology will automatically export a CSV file of all courses.
    • Select All–Selecting this option will select all of the listed courses.
  3. Select fields–Select the course information you’d like to export.
  4. Export–To export a CSV file of the selected information, click the Export button. 
Note: To export courses, all courses must have a Course Code in addition to either a Section Code or Section School Code.

Back to top

Exporting Sections

Use the third tab in the Export area to export your school's course Sections.

  1. Select grading period: Select the grading period(s) associated with the sections you’d like to export.
    • Select Active: Selecting this option will select all current grading periods at your school. Current grading periods are grading periods that have started, but not yet ended.
  2. Choose Sections: Select the section(s) you’d like to export. If there are more than 500 courses associated with the selected grading period(s), Schoology will automatically export a CSV file of all courses.
    • Select All: Selecting this option will select all of the listed sections.
  3. Select fields: Select the section information you’d like to export.
  4. Export: To export a CSV file of the selected information, click the Export button. 

Back to top

Exporting Course Enrollments

Use the fourth tab to export your school's course enrollments.

  1. Select grading period: Select the grading period(s) associated with the sections whose enrollment you’d like to export.
    • Select Active: Selecting this option will select all current grading periods at your school. Current grading periods are grading periods that have started, but not yet ended.
  2. Choose Sections: Select the section(s) you’d like to export. If there are more than 500 courses associated with the selected grading period(s), Schoology will automatically export a CSV file of all courses.
    • Select All: Selecting this option will select all of the listed sections.
  3. Select fields: Select the user information you’d like to export.
  4. Export: To export a CSV file of the selected information, click the Export button. 

Back to top

Exporting Gradebook

From the fifth tab in Export, you can export grades in your school. Grades are calculated in this export as a CSV for import into other system.

  1. Export By: Choose to export by School or Individual Users.
    • School: Choose individual schools or all schools to export all of the grades within a school or schools.
    • Individual Users: Search for individual users to export all grades for that user.
  2. Select grading period: Select the grading period(s) associated with the sections whose grades you’d like to export.
    • Select Active: Selecting this option will select all current grading periods at your school. Current grading periods are grading periods that have started, but not yet ended.
  3. Choose Sections: Select the section(s) you’d like to export. If there are more than 500 courses associated with the selected grading period(s), Schoology will automatically export a CSV file of all courses.
    • Select All: Selecting this option will select all of the listed sections.
  4. Select fields: 
    • Select the user information you’d like to export.
    • What grades would you like to export? (you can specify your option or choose both)
      • Grade Items: Assignments, Test/Quizzes, Graded Discussions
      • Midterm/Final, Overall Grades
  5. Export: To export a CSV file of the selected information, click the Export button. The CSV file will list grades by course section, which you may filter as needed. 
Note: To export courses, all courses must have a Course Code in addition to either a Section Code or Section School Code.

Back to top

Exporting Attendance

Use the sixth tab in the Export area to export attendance in your school.

  1. Export By: Choose to export by School or Individual Users.
    • School: Choose individual schools or all schools to export all of the grades within a school or schools.
    • Individual Users: Search for individual users to export all grades for that user.
  2. Select grading period: Select the grading period associated with the courses whose attendance you’d like to export.
    • Select Active: Selecting this option will select all current grading periods at your school. Current grading periods are grading periods that have started, but not yet ended.
  3. Choose Sections: Select the section(s) you’d like to export. If there are more than 500 courses associated with the selected grading period(s), Schoology will automatically export a CSV file of all courses.
    • Select All: Selecting this option selects all of the listed sections.
    • Add date range: Selecting this option enables you to select the date range of the attendance you would like to export.
  4. Attendance Code: Select the attendance records you'd like to export.
Note: The export can only include present records that have attendance comments, it cannot include present records without comments.

Attendance_Code_icons.png

  1. Select fields: Select the user information you’d like to export.
  2. Export: To export a CSV file of the selected information, click the Export button. The CSV file will list marked attendance (Absent, Late, or Excused) by course section, which you may filter as needed.
Note: If you are using Schoology in a double-byte language, such as Japanese, Chinese, or Korean, you may have to change the encoding of the CSV file to correctly display the characters.

To change encoding settings in Microsoft Excel, open the Options menu. In Excel 2013, you open Options from the File menu in the top row; previous versions of Excel access Options from different locations (the Microsoft logo button in Excel 2010, for example).

  1. Select Advanced from the Options menu.
  2. In the General section, click Web Options.
  3. On the Encoding tab, choose the appropriate language from the Save this document as list: For example, select Japanese (JIS) to display Japanese characters.
  4. Click OK to close the Web Options menu.

Back to top

Auto-Export

The last tab in the Export area is the Auto-Export tool. Review the information in this article for more details.

Back to top


Comments

0 comments

Please sign in to leave a comment.

Powered by Zendesk